Simple VPLS Configuration | LDP Signaling | Cisco | Service Provider

Simple VPLS Configuration | LDP Signaling | Cisco | Service Provider



Help keep us going…

       

In this video I will walk you through configuring a very simple VPLS lab using 3 provider routers and 3 customer edge routers.

0:00 – Introduction
1:18 – Topology Overview
3:57 – Service Instance Configuration
8:50 Pseudowire Interface Configuration
13:04 VFI Configuration (Tying the pseudowires together)
16:28 – Bridge Domain Configuration (Tying the VFI and Service Instance together)
20:22 – Customer Edge Router(s) Configuration
22:28 – Testing Layer 2 Reachability Between Sites
24:30 – Configuring OSPF peering between sites.
29:49 – Thanks for watching and I really hope you learned something!



Don’t Forget to Subscribe on YouTube



*** This video does not demonstrate how to set up LDP neighbors or OSPF for reachability of the loopbacks on the provider routers. I have already pre-configured this so that the main focus of the video would be on the mechanisms that make VPLS work. You will need to have OSPF (or the protocol of your choosing) advertising the loopbacks of the provider routers, as well as LDP neighbors between the provider routers before proceeding. To get you up to speed on what has already been configured, here is a sample configuration for MPLS/LDP and OSPF on CSR-1. ***

Sample MPLS/LDP/OSPF Config (CSR-1):

router ospf 1
router-id 1.1.1.1
mpls ldp autoconfig

int lo0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0

int gi1
ip address 172.16.1.1 255.255.255.252
ip ospf 1 area 0

int gi4
ip address 172.16.1.5 255.255.255.252
ip ospf 1 area 0

 

Leave a Reply

Your email address will not be published. Required fields are marked *